InfyChat

System Requirements

Make sure you have system requirements properly.

For installation, you should have primary knowledge of Laravel and Javascript application installation since this application is built on Laravel with JS.

Primary Requirements:

  • PHP 7.2.+
  • MySQL 5.6+
  • Other PHP Extensions for Laravel mentioned here on Laravel Website
  • Enabled curl extension
  • Certificate Path cacert.pem in your php.ini file. Guide here

Optional: You can also update the below variables in the php.ini file if you want to upload bigger files.

upload_max_filesize = 50M max_file_uploads = 50 post_max_size = 100M

Point the domain to a folder

You will need to create a virtual host to set up InfyChat. You can find steps here to create a virtual host.

  • Steps here to create a virtual host on XAMPP.
  • Steps here to create a virtual host on WAMP.

Point your domain or subdomain to the public directory inside the InfyChat folder.

Please note that InfyChat must be installed on a primary domain or subdomain. Installing on a sub-folder will not work, for example:

example.com/infychat (Invalid) localhost/infychat (Invalid) if you are putting it in a subfolder or root website) example.com (Valid) local.infychat.com (Valid) infychat.test (Valid)

Open the link to the domain in the browser (Example: https://local.infychat.com).